[Date Prev][Date Next] [Thread Prev][Thread Next]
[Date Index] [Thread Index] [New search]

MML Include/Import Problems


Of the 65,000 messages in my personal Framers groups archive, only about 25 
have "MML" in the subject -- either nobody uses it or it always works.

However, I am going nuts trying to solve a problem that does not seem to 
want to be solved.

I am on Framemaker 5.56 on Windows 95.

I am trying to create a single Frame document from multiple MML documents. 
The multiple MML documents are in a directory *structure*; they are not all 
in one directory.  The includes cascade; file include files which include 

I have tried dozens of combinations of methods and I can never quite get 
the correct result.  I CAN get the include path right for importing, but 
not for tagging.

The following directory structure is ONE OF those I have tried.


Master.mml includes "TagsDefined.mml" and "Lists/Aland/AlandTOC.mml"

AlandTOC.mml includes "Lists/Aland/ContentFile-1.mml"

I had to experiment a lot with the pathnames, but it seems that if the FM 
document and the Master.mml document are in the same directory, then the 
pathnames such as "Lists/Aland/ContentFile-1.mml" are correct.

When I import into to my FM document (/u/frame/test/test.fm) Master.mml, I 
*can* get all the content to import.

However, in the FM document, only the content coming from AlandTOC.mml is 
correctly tagged.  The content coming from files included by AlandTOC.mml 
is NOT correctly tagged -- it all has the tagging of the last paragraph in 

Another twist to this which I don't understand is that my database output 
guy apparently came up with a statment in the TagsDefined.mml file
    <!DefineTag !DefineTag >
When this statement is present, ALL the content including the 
"Lists/Aland/ContentFile-1.mml" content DOES come in to the FM file. 
However, the lower-level content is not properly tagged in FM (as described 
above).  If I remove the <!DefineTag !DefineTag > statement from 
TagsDefined.mml, then the content from the lower level files does NOT COME 
IN at all -- only the content from Master.mml comes in.  I have tried 
moving the <!DefineTag !DefineTag > statement in TagsDefined.mml around (up 
and down in the file) with varying results.  I am not sure what it is doing 
  or why it is doing it.

When I originally tested the concept of including files that include files 
that include files, I failed to test including a "TagsDefined.mml" file 
that defines the paragraph tags.  I was focusing on getting the paths correct.

I seem to have the paths correct, but the tag definitions are simply not 
working.  YES, I do have the tagnames defined in my FrameMaker document and 
YES, I have them spelled correctly, etc.

In the FrameMaker console window, I am also getting some error messages 
which simply don't make sense to me:

MML Import Error: Junk at end of command: 'Default-Description-3 '.

Default-Description-3 is one of my tagnames [don't ask].  What does this 
MML import error refer to?  I have removed any possible junk from the 
files, etc., etc.   The mml files are being generated on a Red Hat linux 8 
system and have 8859-1 encoding.  The FrameMaker is on a Windows 95 
machine.  I have tried running "unixtodos" on the mml files to deal with 
potential line-ending differences, but that seemed to have no effect.

Any ideas?????


Jay Smith

e-mail: Jay@JaySmith.com  mailto:Jay@JaySmith.com
website: http://www.JaySmith.com

Jay Smith & Associates
P.O. Box 650
Snow Camp, NC  27349  USA

Phone: Int+US+336-376-9991
Toll-Free Phone in US & Canada:
Fax: Int+US+336-376-6750

** To unsubscribe, send a message to majordomo@omsys.com **
** with "unsubscribe framers" (no quotes) in the body.   **