[Date Prev][Date Next] [Thread Prev][Thread Next]
[Date Index] [Thread Index] [New search]

Frame 7 Structured App Problem

I just delivered to a client a structured application, including EDD, 
Template, Read/Write rules, DTD, and miscellaneous other files. The 
application is used to generate a 400+-page illustrated product catalog 
from a database which outputs SGML instances containing the product listings.

This recently delivered application is an updated version of the same 
application which the client used last year to successfully produce the 
same catalog. All of the development work for the original application, as 
well as that for the upgraded version, was done in FM+SGML 6. Before 
delivering the application, I fully tested everything, and it all worked. 
Files which were not modified from last year's version (e.g., application 
definition file, SGML declaration) were not re-delivered, and all the 
upgraded files have the exact same names as those in the earlier version. 
In the case of the Read/Write Rules file, the delivered version specifies 
in the first line:
fm version is "7.0"
as is required for operation with Frame 7.0.

I have verified that the client installed all of the replacement files in 
the same folder used last year. But after the files had been installed and 
the FrameMaker 6.0 files were upgraded to 7.0, he checks the Read/Write 
Rules with the structured application set to the correct one, and the error 
log reports that it cannot find file isoall.rw . So then I told him to 
delete the #include "isoall.rw" line. This time, the error log reported 
that it could not read the DTD.

We verified that the isoall.rw file was where it is supposed to be, that 
the new DTD did overwrite the old version, and that the application 
definition file has the correct file and pathnames. By the way, the entire 
application is installed in a folder under the Structure Tools\sgml folder, 
thus the appdef file specifies $STRUCTDIR\sgml as the prefix to all 
pathnames declared therein.

So then, I had the client reinstall the old version of the application 
(which we knew worked). The reinstall overwrote the upgraded version of the 
files with the old ones. When the read/write rules were checked, the same 
errors occurred.

Next, I instructed him to go into the Docbook folder (he's never before 
done anything in DocBook, so it is pristine), open, reread and save the 
appdef file contained therein, then open the Docbook RW Rules file, and 
check the read/write rules with the Docbook 2.1 structured application 
selected. The exact same error log --cannot find isoall.rw was produced.

The client did recently get the patches and upgrades for Frame 7, and 
claims he installed them in the proper order.

Has anyone else run into a problem like this on Frame 7, and if so, how did 
you fix it?

FrameMaker/FrameMaker+SGML Document Design & Database Publishing
DW Emory <danemory@globalcrossing.net>

** To unsubscribe, send a message to majordomo@omsys.com **
** with "unsubscribe framers" (no quotes) in the body.   **